2015年4月27日

Pacman 4.2.1 更新需要手動調整

在您的下一次更新,pacman 將會更新到 4.2.1,這是由 Arch Linux 的開發者所提供的最新版本。您將會在這次更新完成後,再次執行「sudo pacman -Syu」時看到下列的錯誤訊息:

錯誤:alpm函式庫初始化失敗
(資料庫版本不對: /var/lib/pacman/)
錯誤:  請嘗試運行 pacman-db-upgrade


要修復此錯誤訊息,請按其建議執行:
sudo pacman-db-upgrade

在此之後,pacman 應該就能正常運作了。

Pacman 4.2 及以上將不再把目錄的符號連結視為目錄。如果套件包含了安裝到在檔案系統上是符號連結的目錄的檔案的話,安裝將會失敗。這種類型的目錄的一些常見位置為 /sbin、/bin、/lib、/lib64、/usr/lib64、/var/run。團隊試著找到並修復所有受影響的套件,但您若仍有安裝到受影響的在官方套件庫中的套件,請至錯誤追蹤系統回報。如果您維護著 CCR 上其中一個受影響的套件,請檢查您的套件是否安裝檔案到已符號連結的目錄中。您可以使用「file」指令來測試特定目錄是否為符號連結。倘若使用者有任何疑惑,或者您遇到其他問題,歡迎上論壇詢問或回報。

一如既往的,請在更新前確定您的映像站已完成同步(至少必須確認 core 已同步)。可以在 konsole下執行 mirror-check,或使用在網際網路類別底下的鏡像站檢查軟體以確認。

新聞來源:Pacman 4.2.1 update needs manual intervention

沒有留言:

張貼留言